Skip All Navigation

How To Use

Minimum System Requirements

Internet Connection:

The entire site can be viewed using a variety of internet connection speeds. There are several multimedia videos that may be slower than the rest of the site to download. If you prefer, the text of each video can be viewed by accessing the link just below the video.

Browser Requirments:

The newest versions of Internet Explorer and Mozilla Firefox are recommended. The course has been tested with older versions and you should have at a minimum, Internet Explorer 6.0 or Mozilla FireFox 1.0

Adobe Flash Plug In:

Some course interactivity has been built using Adobe Flash. If your browser does not have this plug in installed, you can download it at the Adobe Download Center.

 

< Back      Next >